Abnormal delays in the processing of bulks
Incident Report for Hunter
Resolved
This incident has been resolved and the queue is being emptied right now. We've increased the number of servers to help.
Posted over 1 year ago. Aug 08, 2017 - 18:41 CEST
Investigating
The processing of new bulk verifications, searches and finders are taking an abnormally long time. We're investigating and we'll update as soon as we know more.
Posted over 1 year ago. Aug 08, 2017 - 15:03 CEST