Partial outage
Incident Report for Hunter
Resolved
This incident has been resolved.
Posted 24 days ago. Jun 24, 2019 - 15:05 CEST
Identified
Our service is currently unavailable for one-third of our users due to what seems to be a Cloudflare outage. We will update as soon as we know more.
Posted 24 days ago. Jun 24, 2019 - 13:01 CEST
This incident affected: Website & API, Chrome Extension, MailTracker, and Blog.