Critical outage
Incident Report for Hunter
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jul 06, 2017 - 15:14 CEST
Investigating
We're experiencing issues and are currently looking into it. We'll update the status of this incident as soon as we know more.
Posted almost 2 years ago. Jul 06, 2017 - 14:57 CEST