Delay in sending campaigns
Incident Report for Hunter
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 24, 2018 - 15:01 CEST
Identified
We are currently fixing two different bugs preventing users to send campaigns. We expect a final resolution within the hour.
Posted about 1 year ago. Jun 24, 2018 - 14:44 CEST
Investigating
We are currently investigating issues with the campaign editor. We'll update this status as soon as we know more.
Posted about 1 year ago. Jun 24, 2018 - 11:15 CEST
This incident affected: Website & API.