Higher than usual response times for the Email Finder
Incident Report for Hunter
Resolved
This incident has been resolved. We apologize for the trouble. During the day, we learned a lot, and we'll use this knowledge to ensure the problem doesn't occur again in the future.

If you're still experiencing technical issues, please reach out: contact@hunter.io
Posted 16 days ago. Jan 06, 2018 - 20:16 CET
Update
We're still working on better understanding the problem. Most of the times, response times are higher than usual. On rare occasions, we're seeing timeouts. We will update as soon as we know more.
Posted 16 days ago. Jan 06, 2018 - 09:56 CET
Investigating
We are currently investigating this issue.
Posted 16 days ago. Jan 06, 2018 - 07:26 CET